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� In Windows, double-click the
Photoshop application icon.

� In Windows, click Adobe Photoshop CS.

� In Mac, click the Adobe
Photoshop CS icon in the Dock.

Welcome to Photoshop 8—Er...CS!
In this chapter (which is more of a read
than a do), you’ll learn how to launch
Photoshop and get acquainted with the
Photoshop interface—menus, palettes, 
and whatnot. You can use this chapter as a
reference guide as you work. The next chap-
ter, which is an introduction to color in
Photoshop, is more theory than technique,
too. From Chapter 3 onward, though, it’s
nonstop action.

To launch Photoshop in Windows:
In Windows 2000 or XP, click the Start 
button on the taskbar, choose All Programs,
then click Adobe Photoshop CS �. 
or
Open the C: \ Program Files \ Adobe\
Photoshop CS folder in My Computer, then
double-click the Photoshop application 
icon �.
or
Double-click a Photoshop file icon.

To launch Photoshop in Macintosh:
In Mac OS X, click the Photoshop icon in
the Dock �. (If you don’t have an icon
there yet, open the Adobe Photoshop CS
folder in the Applications folder, then drag
the Adobe Photoshop CS application icon
into the Dock.)
or
Open the Adobe Photoshop CS folder in
the Applications folder, then double-click
the Adobe Photoshop CS application icon.
or
Double-click any Photoshop file icon.

Too hearty a welcome?
When you launch Photoshop, a welcome screen
pops up, offering you access to an online tutorial, 
color management information, lists of new features
in PDF format, etc. If you get tired of seeing it,
uncheck Show this dialog at startup.
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7 Toolbox

The Photoshop screen in Macintosh

8 The status bar displays Document Sizes, Document Profile, Document
Dimensions, Scratch Sizes, Efficiency, Timing, or Current Tool information.

4 Title bar (zoom level, current layer
name, image mode, and bit depth)2 Close, minimize, zoom buttons

9 Color/Swatches/
Styles palettes

3 Options bar

1 Menu bar
Press any menu heading to access dialog
boxes, submenus, and commands.

2 Close, minimize, and zoom buttons
To close a file or a palette, click its close (red)
button. Click the minimize (yellow) button to
stow it in the Dock. Click the zoom (green)
button to enlarge a window to maximum size,
or on a palette to show/hide extra options.

3 Options bar 
Use to choose settings for the current tool.

4 Title bar 
Displays the image’s title, zoom level, current
layer (or the Background), image mode, and
bit depth.

5 Palette well 
Use to store and open palettes.

6 Rulers 
Choose View > Show Rulers to display rulers.
The position of the pointer is indicated by 
a mark on each ruler.

7 Toolbox 
Press Tab to show/hide the Toolbox and all
open palettes. 

8 Status bar 
The status bar displays Document Sizes,
Document Profile, Document Dimensions,
Scratch Sizes, Efficiency (the percentage of
time Photoshop is processing edits, as
opposed to writing to the scratch disk),
Timing, or Current Tool information. To
reset the timer, choose Timing with Alt/
Option held down.

9 Palettes 
There are 19 movable palettes. Click a tab
(palette name) in a palette group to bring
that palette to the front of its group.

Key to the Photoshop screen: Macintosh and Windows features

6 Rulers

Image
window

1 Menu bar

5 Palette well
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Toolbox
Color palette

Swatches palette

The Photoshop screen in Windows

Title bar (zoom level, current layer
name, image mode, bit depth)

Document 
minimize
button

Document
maximize
button

Document
close button

Palette well

Menu bar

Document
Control menu

1 Application
Control menu 2 Application minimize button

4 Application close button

3 Application maximize button

The status bar displays Document Sizes,
Document Profile, Document Dimensions,
Scratch Sizes, Efficiency, or Timing information.

1 Application (or document) Control menu
The application Control menu commands 
are Restore, Move, Size, Minimize, Maximize,
and Close. The document Control menu 
commands are Restore, Move, Size, Minimize,
Maximize, Close, and Next.

2 Application (or document) minimize button
Click the application minimize button to
shrink the document to an icon in the taskbar.
Click the icon on the taskbar to restore the
application window to its previous size.
Click the document minimize button to
shrink the document to an icon at the lower

Key to the Photoshop screen: Windows-only features

Image window

Options bar

left corner of the application window. Click
the restore button to restore the document
window to its previous size.

3 Application (or document) maximize/restore
button 
Click the application or document maximize
button to enlarge a window to its largest possi-
ble size. Click the restore button to restore a
window to its previous size. When a window is
at the restored size, the restore button turns
into the maximize button.

4 Application (or document) close button
Closes the application (or image).

A minimized window, 
showing the 
restore button
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File menu 
Use commands on
the File menu to 
create, open, close,
save, place, scan,
import, export, and
print images; open
the File Browser;
automate opera-
tions; and exit
Photoshop. Use the
Jump To submenu 
to switch to a helper
application, such 
as Adobe Illustrator 
or GoLive. (In Mac,
the Quit Photoshop
command is on the
Photoshop menu.)

Image menu
An image can be converted to any 
of eight image (color) modes via the
Mode submenu. The Adjustment 
commands modify an image’s hue, 
saturation, brightness, contrast, etc. 
The Image Size command modifies 
an image’s file size, dimensions, or 
resolution. The Canvas Size dialog 
box is used to add or subtract from an
image’s live canvas area. Other com-
mands rotate, crop, or trim the canvas.

Layer menu
Layer menu com-
mands create, dupli-
cate, delete, apply
styles to, rasterize,
arrange, align, dis-
tribute, merge, and
flatten layers. Other
commands add,
remove, or disable
layer, vector, and
clipping masks.
Some of these com-
mands can also be
chosen from the
Layers palette menu.

The menus

Edit menu 
The Edit menu is a
storehouse of image-
editing commands
that copy, transform,
and paste imagery;
apply fills and strokes;
and create custom
brushes, patterns, and
shapes. Fade lessens
the effect of the last
edit; the Purge com-
mands free up mem-
ory. Also found here
are commands for
word processing, for
managing presets,
and for customizing
shortcuts. (In Mac, 
the Preferences and
Color Settings com-
mands are on the
Photoshop menu.)
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Filter menu
Filters, which perform 
a wide range of image-
editing functions, 
are organized into 
submenu groups.
Extract allows you 
to make complex sil-
houettes, the Filter
Gallery allows you to
apply multiple filters,
Liquify pushes pixels
around, Pattern Maker
creates seamless pat-
terns from selections,
and Digimarc embeds
a copyright watermark.

Select menu
The All command on the
Select menu selects an
entire layer. Deselect 
deselects all selections, 
Reselect restores the last
deselected selection, and
Inverse swaps the selected
and unselected areas. The
Color Range command
creates a selection based
on image color. Other
Select menu commands
enlarge, contract, smooth,
or feather selection edges, 
as well as save selections
to and from channels. 

Help menu
Use Help menu
commands to
access Photoshop
onscreen help, 
get the latest news
from Adobe, 
connect to Adobe
Online, or per-
form automated
tasks via onscreen
prompts. (Not all
the commands
shown here are
available in Mac.)

View menu
Commands on the View menu control what
features are visible onscreen. Use this menu
to show/hide rulers, grids, guides, slices,
selection edges, the currently selected 
(target) path, or annotations, or to change
the current zoom level or screen mode. The
Proof Setup commands allow you to see how
your image will look in different output color
spaces, and the Gamut Warning highlights
colors that won’t print on a four-color press.  

Window menu
The Window menu is used primarily for
showing and hiding the 19 palettes. Open
images can also be activated via this menu
and arranged via Arrange submenu com-
mands. Workspace commands allow you to
customize your workspace. In Windows, the
Status Bar command for showing/hiding
the status bar is also found on this menu.



Using the Toolbox
To choose a tool whose icon is currently 
visible, click once on its icon. Click the 
itty bitty arrowhead next to a tool icon to
choose a related tool from a pop-out menu. 

Or even better, choose a tool using its short-
cut (try to memorize the boldface letters on
the next three pages). If you forget a tool’s
shortcut, just leave the cursor over the tool
icon for a moment, and the tool tip will
remind you �. To cycle through hidden,
related tools on a pop-out menu that also
share the same shortcut, press Shift plus 
the shortcut key. You could also Alt-click/
Option-click the currently visible tool icon.
Note: If Use Shift Key for Tool Switch is
unchecked in Edit (Photoshop, in Mac) >
Preferences > General, you can just press
the letter without using Shift.

Attributes are chosen for each tool (e.g.,
blending mode, opacity percentage) from
the options bar at the top of the screen
(read more about the options bar on 
page 11) �. Features on the bar change
depending on which tool is selected. 

Options bar settings remain in effect for an
individual tool until they’re changed or the
tool is reset. You can save settings as presets
in the Tool Preset palette (see page 28). 
To reset a tool to its defaults, right-click/
Control-click the tool thumbnail on the
options bar, then choose Reset Tool from
the context menu �. Or to reset all tools,
choose Reset All Tools from the same menu.

If you try to use a tool incorrectly, a cancel
icon will appear. Click in the image 
window to make an explanation appear. 

TIP Choose whether tool pointers look like
their Toolbox icon or a crosshair in Edit
(Photoshop, in Mac) > Preferences >
Display & Cursors.
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�

� Choose options for the current tool from the options bar at the top of your screen.

� To access the Reset Tool command for
an individual tool or the Reset All Tools
command for all tools, right-click/Control-
click the tool thumbnail on the options bar.

Tool tips
Rest the pointer on a tool icon—
without clicking or pressing the
mouse button—to learn that
tool’s name or shortcut �. Use
the same method to learn the
function of a palette or options
bar feature �. Check Show Tool
Tips in Edit (Photoshop menu, in
Mac) > Preferences > General to
enable this feature.

Tool shortcuts
Hide/show the Toolbox Tab

and all open palettes

Cycle through hidden, Shift plus shortcut key*
related tools on the  or Alt-click/Option-click 

same pop-out menu the currently visible tool

Cycle through blending Shift-+ (plus) or
modes for the current Shift - - (minus)

editing tool or layer

*If Use Shift Key for Tool Switch is checked in Edit

(Photoshop, in Mac) > Preferences > General
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The Toolbox

VMove 
Moves a layer, selection, or guide

WMagic Wand 
Selects similarly colored pixels 

KSlice
Slices images for optimization

B Brush
Applies brushstrokes

Y History Brush
Restores pixels from a designated state

G Gradient 
Creates color blends

O Dodge  
Lightens pixels

T Horizontal Type 
Creates editable type on its own layer

U Rectangle  
Draws rectangular shapes

I Eyedropper  
Samples colors from the image

Z Zoom
Changes the zoom level

X Switch foreground/
background colors

Background color square 

QQuick Mask mode 

F Full screen with no 
menu bar 

F Full screen with menu bar 

Rectangular Marquee M
Creates rectangular selections 

Lasso L
Creates freehand selections 

Crop C
Crops the canvas

Color Replacement J
Changes colors, preserves texture

Clone Stamp S
Clones imagery

Eraser E
Erases pixels

Blur R
Blurs edges

Path Selection A
Selects paths

Pen P
Draws curved or straight paths

Notes N
Creates nonprinting annotations

Hand H
Moves the image in its window

Foreground color square 

Default colors D
Black and white

Standard mode Q

Standard windows F

Edit in ImageReady  
Ctrl-Shift-M/Cmd-Shift-M

Click here to go to the Adobe website

new

(Continued on the following page)
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L Polygonal Lasso
Creates polygonal selections

L Magnetic Lasso
Creates snap-to freehand selections

S Pattern Stamp
Applies patterns

M Elliptical Marquee
Creates oval selections

Single row
Creates 1-pixel-high selections

Single column
Creates 1-pixel-wide selections

E Background Eraser
Erases the sampled color to transparency 

E Magic Eraser
Erases color areas by clicking

R Sharpen
Sharpens pixels

R Smudge
Smudges pixels

J Healing Brush
Corrects flaws by hand

J Patch
Corrects flaws using a selection
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N Audio Annotation
Creates audio annotations

K Slice Select
Selects slices by clicking

B Pencil
Draws freehand lines

Y Art History Brush
Paints a history state or 

snapshot in stylized
brushstrokes

A Direct Selection
Selects segments and points

on a path

P Freeform Pen
Draws freehand paths

Add Anchor Point 
Adds points to a path

Delete Anchor Point 
Deletes points from a path

Convert Point
Converts corner points into

curve points, and vice versa

G Paint Bucket
Fills similarly colored

areas by clicking
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� An annotation created using the
Notes tool

Annotate
The Notes tool creates nonprinting
Acrobat-compatible notes, which can be
used for communicating with a client,
output service, etc. � When you click a
note icon, a note window containing the
message opens. The Audio Annotation
tool creates audio notes. 

U Rounded Rectangle
Creates rectangular shapes with

rounded corners

U Ellipse
Creates oval shapes

U Polygon
Creates polygonal shapes

U Line
Creates straight lines

U Custom Shape
Creates predefined custom shapes

O Burn
Darkens pixels 

O Sponge
Saturates or desaturates pixels

I Color Sampler
Places color sampler points 

I Measure
Measures distances and angles

T Vertical Type
Creates vertically oriented type

T Horizontal Type Mask 
Creates a horizontal type-

shaped selection 

T Vertical Type Mask 
Creates a vertical type-shaped

selection
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Options bar
The options bar is used to choose settings
for each tool (e.g., Opacity, Flow, blending
Mode). Options on the bar change depend-
ing on which tool is currently chosen, and
your choices remain in effect until you
change them. Like the palettes, the options
bar can be dragged to a different part of
your screen. Double-click the left edge 
of the options bar to collapse/expand it.

The palette well on the options bar is 
discussed on page 12.

The options bar for the Rectangular Marquee tool

The options bar for the Brush tool

The options bar for the Gradient tool

The options bar for the Pen tool

The options bar for the Type tool

Press this arrowhead to open the pop-up palette menu.

Click this button to create a new
preset from the current brush.

To close the Brush Preset picker
or any other pop-up palette, click
anywhere outside it or click the
arrowhead on the options bar.

Click the Brush arrowhead to open the Brush Preset picker (it’s a pop-up palette).
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� To separate a palette from its group,
drag the tab (palette name) away from
the palette group.

� The Swatches palette is now going solo.

either by dragging the palette into the well
� or by choosing Dock to Palette Well from
the palette menu.

If the current tool uses a particular palette
(e.g., the Pencil tool uses the Brushes
palette, the type tools use the Character
palette), you can click the Toggle palette
button on the options bar to show/hide
that palette.

To shrink/expand a palette, double-click 
its tab. In Windows, you can also click the
palette minimize/maximize button. If the
palette isn’t at its default size, click the mini-
mize box/zoom (green) button once to
restore its default size, then click it a second
time to shrink the palette.   

TIP Quick-change: Click in a field on a
palette or in a dialog box, then press 
the up or down arrow on the keyboard
to change that value incrementally.

Press this arrow-
head to choose
commands from
the palette menu.

�

The palettes
How to use the palettes
Many Photoshop operations are triggered by
choosing commands on movable palettes. 
To save screen space, the palettes are joined
into default groups, such as History/Actions
and Color/Swatches/Styles. 

To open a palette, choose its name from the
Window menu. The palette will appear in
front within its group. 

Press Tab to show/hide all open palettes,
including the Toolbox. Press Shift-Tab 
to show/hide all open palettes except 
the Toolbox.

To display an open palette at the front of 
its group, click its tab (palette name). 

You can separate a palette from its group by
dragging its tab �–�. You can add a palette
to any group by dragging the tab into the
group. If you need to widen a palette to make
additional tabs visible, drag the palette’s
resize box (lower right corner). Most of the
palettes are resizable. 

You can dock (store) palettes in the palette
well on the right side of the options bar,



If Save Palette Locations is checked in 
Edit (Photoshop, in Mac) > Preferences >
General, palettes that are open when 
you exit/quit Photoshop will reappear in
their same location when you relaunch 
the program. 

To further customize your onscreen working
environment, you can set up special config-
urations of palettes and dialog boxes for 
different kinds of tasks and save them as
workspaces. For example, you might want to
keep the Character and Paragraph palettes
open any time you’re working on a text-
intensive document, or create a workspace
in which the Brushes, Color, and Swatches
palettes are open and accessible for use
when painting.

To create a custom workspace:
1. Display whichever palettes you want

open and accessible, and arrange them
on the screen as you like. 

2. Choose Window > Workspace > Save
Workspace. 

3. Enter a descriptive Name for the new
workspace, then click Save. The new
workspace is now accessible on the
Window > Workspace submenu.

To delete any or all custom workspaces:
1. Choose Window > Workspace > Delete

Workspace.

2. Choose the name of the workspace you
want to get rid of, or choose All �.

3. Click Delete, then click Yes.

TIP To restore the palettes’ default group-
ings and locations at any time, choose
Window > Workspace > Reset Palette
Locations.
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� In the Delete Workspace dialog box, choose a
workspace name, or choose All.

Change your values
You can change most numerical values simply by
clicking the option name and dragging to the left 
or the right. Examples of options that this works for
are the Width and Height values in dialog boxes,
Opacity and Fill on the Layers palette, Feather on
the options bar, Input Levels and Output Levels in
the Levels dialog box, and Fuzziness in the Color
Range dialog box.

There are two ways to use a pop-up slider �:
Either press an arrowhead and drag the slider in 
one move, or click the arrowhead and then drag the
slider. To close a slider, click anywhere outside it or
press Enter/Return. If you click the arrowhead to
open a slider, pressing Esc will restore its last setting.

new

� A pop-up slider on the options bar.



Actions palette
You can record a series of commands in an
action, and then replay that action on one
image or on a batch of images. The Actions
palette is used for recording, storing, editing,
and replaying actions.
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New Action 

Recorded
command

Action

Actions set

Dialog control

Turns an action 
command on or off

Play

New SetRecord Delete
Current
Action 

The game plan
The palettes are illustrated in alphabetical
order, starting on this page except, that 
is, for the indispensible Toolbox, which is
illustrated on pages 7–10, and the options
bar, which is illustrated on page 11.

Stop
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Brushes palette
The Brushes palette is used for customizing
brush tips for the Brush, Pencil, History
Brush, Art History Brush, Clone Stamp,
Pattern Stamp, Eraser, Background Eraser,
Blur, Sharpen, Smudge, Dodge, Burn, and
Sponge tools. Options on the palette are
organized into categories, such as Shape
Dynamics, Scattering, Texture, and Color
Dynamics. You can also use the Brushes
palette to choose options for a stylus or for
an airbrush input device.

TIP The numeral under a brush tip icon is
the diameter of the tip, in pixels.

Brush editing
categories

Brush tips

Individual
brush options

Brush stroke
preview

New Brush Delete Brush

� Click here to open 
the Brush Preset picker.

Picker or palette?
Brush tips for the painting and editing tools can
be chosen either from the Brushes palette (illus-
trated below) or from the Brush Preset picker �,
a pop-up palette that you open from the options
bar. To close the Brush Preset picker, click outside
it or click the Brush arrowhead again. To hide the
Brushes palette (but keep it open), dock it into 
the palette well on the options bar; to redisplay it,
click the palette tab in the well.

Commands for loading, appending, and saving
brushes and brush libraries can be chosen from
the Brushes palette menu or the Brush Preset
picker menu (click the palette menu button 
on the right side). 
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The eye icon indicates that this channel is
currently visible. To display a channel by
itself in the image window, click its name
or use the keystroke listed on the palette. 

Load Channel
as Selection Save Selection

as Channel 

Delete Channel

New Channel 

A user-created
alpha channel

A user-created 
spot color channel

Channels palette
The Channels palette is used for displaying
one or more of the color channels that make 
up an image. It is also used for creating and
displaying alpha channels, which are used 
for saving selections, and spot color channels,
which are used for producing individual spot
color plates.
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Character palette
When a type tool is chosen, type attributes
can be chosen via the Character palette,
illustrated below, or from the options bar.

Font

Horizontal scale

Leading

Tracking

Point Size

Kerning

Vertical Scale

Baseline Shift

Type Styles

Language

Anti-aliasing

New commandsnew



Color palette
The Color palette is used for mixing and
choosing colors. Colors are applied with 
a painting or editing tool, or via a command
such as Fill or Canvas Size. Choose a color
model for the palette from the palette
menu. Mix a color using the sliders, or
quick-select a color by clicking on the color
bar at the bottom of the palette.   

To open the Color Picker, from which you
can also choose a color, click once on the
Foreground or Background color square 
if it’s already active, or double-click the
square if it’s not active. 
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This is the Foreground color square. The
currently active square has a white border.

Background color square 

Choose a color model for the palette.

Quick-select a hue by
clicking the color bar.

Choose a different 
spectrum for the color bar.



File Browser palette 
The File Browser enables you to search for,
open, sort, batch-process, move, rename, 
and delete Photoshop files. Images in the 
currently selected folder are represented by
image thumbnails in the main window. The
File Browser in Photoshop CS boasts a num-
ber of new features, such as buttons at the top
of the palette, palettes on the left side, and
menus that let you activate many commands.

19
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FOLDERS

New menus!

New buttons!

MAIN PANE

PREVIEW

METADATA,
KEYWORDS

Rotate Image Counterclockwise

Rotate Image
Clockwise Search

Delete
Flag
File

New palettes!
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Histogram palette
The Histogram palette (formerly a dialog
box) diagrams the current light and dark
values of an image, or its before and after
light and dark values as it’s being edited 
or while an adjustment dialog box is open.
Via the Channel pop-up menu, you can
choose to have the palette display infor-
mation about the combined channels 
or about just one channel. You can also
expand the palette to display histograms
for every channel. The screenshot at right
shows the palette in Expanded View (the
other display options are Compact View
and All Channels View).

History palette
The History palette is used to selectively
undo one or more previous steps in a work
session. Each brushstroke, filter applica-
tion, or other image-editing command is
listed as a separate state on the palette,
with the bottommost state being the most
recent. Clicking on a prior state restores
the document to that stage of the editing
process. What happens to the document
when you click on a prior state depends
on whether the palette is in linear or non-
linear mode. 

In linear mode, if you click back on and
then delete a state or resume image 
editing from an earlier state, all subse-
quent states (dimmed, on the palette) will
be deleted. In non-linear mode, you can
click back on an earlier edit state or delete
a state without losing subsequent states.
This option is turned on or off via the
Allow Non-Linear History check box in
the History Options dialog box (choose
History Options from the palette menu).
You can switch between linear and non-
linear modes at any time during editing.

The New Snapshot command creates a
state that stays on the palette until the
image is closed. The History Brush tool
restores an image to a designated prior
state where the brush is dragged in the
image window. The Art History Brush does
the same thing, but in stylized strokes.

The current source 
for the History Brush

This is the History palette in linear mode. Note
that some steps are dimmed. 

History State
slider (at the
current state) New Snapshot

New Document
from Current
State

Delete
Current
State

new



The current x/y
location of the
pointer on the image

Info palette
The Info palette displays a color breakdown
of the pixel that’s currently under the
pointer �. The palette will also show read-
outs for up to four color samplers, if they’re 
placed on the image �. If a color adjust-
ment dialog box is open, the palette will 
display before and after color readouts. The
Info palette also shows the x/y location of
the pointer on the image. 

Other information may display on the
palette, depending on which tool is being
used, such as the distance between points
when a selection is moved, a shape is drawn,
or the Measure tool is used; the dimensions
of a selection or crop marquee; or the 
width, height, and angle of a selection as 
it’s being transformed �. 

Press one of the tiny arrowheads to choose 
a color mode for that readout (it can be 
different from the current image mode):
Actual Color (the current image mode),
Proof Color, Grayscale, RGB Color, Web
Color, HSB Color, CMYK Color, Lab Color,
Total Ink, the current layer Opacity, or 16-bit. 

To do this via a dialog box, choose Palette
Options from the palette menu, then change
the mode for the First and Second Color
Readouts. You can also change the unit 
of measurement for the palette (Mouse
Coordinates), and for an image in 16-bit
mode, you can check Show 16 bit values �.

TIP If an exclamation point appears next 
to a color readout, it means that color 
is outside the printable, CMYK gamut.

� Color breakdown for the pixel
that’s currently under the pointer

Press an arrowhead to
choose a different color
mode for that readout.

Press this arrowhead to
choose a different unit
of measurement for the
palette (and the rulers).

� During a transform operation, the width (W),
height (H), angle (A), and horizontal skew (H)
or vertical skew (V) of the transformed layer,
selection, or path are shown in this area.

The Width and Height
of the current selection

� #1, #2, #3, and #4 color readouts on the
Info palette from four color samplers that were
placed on the image

� Choose options for different areas of the
Info palette via the Info Options dialog box.
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Layer Comps palette
A layer comp (short for “composition”) is a
set of layer characteristics, including visibil-
ity, position, and appearance (layer styles).
The purpose of layer comps is to enable
multiple versions of the same image to coex-
ist in one Photoshop or ImageReady file,
and to provide a convenient palette mecha-
nism for displaying them. This can be useful
when you need to present design variations
to a client.

Layer comps are saved to the Layer Comps
palette with the image in which they’re 
created and are applied to a whole image
simply by clicking the comp name on the
palette. Whereas histories affect all editing
done to an image (and can’t be saved), layer
comps remember and apply only specific
layer options and settings. 
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new

Apply
Layer
Comp

Caution icon (indicates the layer
comp can’t be fully restored)

Apply
Next

Apply
Previous

Update
Layer
Comp

New
Layer
Comp
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Add Layer/
Vector Mask

Blending mode 
pop-up menu

The current 
(active) layer (in

this case, an
editable type layer)

Lock Transparent
Pixels, Lock Image

Pixels, Lock
Position, and 

Lock All buttons

Link icon

Click in the eye 
column to show/

hide that layer.

Layer Opacity

New Set New Fill/Adjustment
Layer pop-up menu

Add Layer Style pop-up menu

Layers palette
Each new image starts out with a Background,
which can be a solid color or transparent.
Using the Layers palette, you can add layers
on top of the Background, that you can
show/hide, duplicate, group, link, delete, 
or restack. Each layer can be assigned its 
own blending mode, opacity, and fill opacity
without affecting the other layers. 

In addition to standard layers, you can also
create three other kinds of layers: adjust-
ment layers, which are used for applying
temporary color or tonal adjustments to 

Adjustment layer
thumbnail

Adjustment
layer mask

Layer mask 

Layer Fill opacity

New
Layer

Delete
Layer

Starting out transparent
To have the bottommost tier of a new image be 
a layer with transparency instead of an opaque
Background, in the File > New dialog box, click
Contents: Transparent.

the layers below it; editable type layers,
which are created automatically when the
Horizontal Type or Vertical Type tool is used;
and shape layers, which contain vector shapes
with a color or pattern fill. If you apply a layer
effect to a layer (e.g., Inner Glow or Drop
Shadow), a layer effect icon and pop-up
menu will appear next to the layer name.
You can also attach a mask to a layer. 

Only the current (or “active”) layer can be
edited. To choose a layer, click next to its
name or click its thumbnail. 
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Navigator palette
The Navigator palette is used for moving 
an image in its window and for changing the
zoom level of an image.

Zoom Out
button

Zoom In
button

Zoom slider

Enter the desired zoom
percentage (or enter a
ratio, as in 1:1 or 4:1),
then press Enter/Return.

Drag in the view box to move a
magnified image in its window.
Ctrl-drag/Cmd-drag in the 
view box to marquee an area 
for magnification.

Horizontal
Alignment

Indent Left Margin

Indent First Line

Add Space Before
Paragraph

Auto-hyphenate

Add Space After
Paragraph

Indent Right
Margin

Paragraph palette
The Paragraph palette is used to apply para-
graph-wide attributes to type, including 
horizontal alignment, indentation, space
before, space after, and auto hyphenation.
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Paths palette
A path is a vector shape that’s composed of
curved and straight line segments connected
by anchor points. A path can be drawn
directly with a shape tool or a pen tool, or
you can start by creating a selection and then
convert the selection into a path. To create 
a precisely drawn selection, you can draw a
path and then convert it into a selection. 

Once a path is drawn, you can apply a fill 
or stroke color to it or use the Pen tool or
any of its relatives—the Add Anchor Point,
Delete Anchor Point, or Convert Point
tool—to reshape it. Paths are saved, acti-
vated, duplicated, and deleted via the 
Paths palette. 

TIP While a shape layer or an image layer 
that has a vector mask is selected, the
path for that vector mask will be listed 
on the Paths palette.

Stroke Path
(with brush)

Fill Path (with
Foreground color)

Load
Path as
Selection

Work Path
from Selection

New Path

Delete
Current
Path

A saved path
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Styles palette
The Styles palette is used to save and apply
previously saved individual layer effects or
combinations of effects. Custom style
libraries can be loaded, appended, and saved
using commands on the Styles palette menu.

Style thumbnails Clear
Style

Load in style libraries from
this part of the palette menu.

New
Style

Delete
Style
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Swatches palette
The Swatches palette is used for saving and
choosing already mixed colors. Individual
swatches can be added to or deleted from
the palette. Custom swatch libraries can 
also be loaded, appended, and saved using
commands on the Swatches palette menu. 

Color swatches

Load in color swatch
libraries from this part

of the palette menu.
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New Tool Preset

Delete Tool Preset

Tool Presets palette
You can save and reuse tool settings, just as
you can any other type of preset. Say, for
example, you frequently resize and crop
images to a particular set of dimensions. If
you create a preset with the width, height,
and resolution parameters you need, the
next time you perform the cropping opera-
tion, instead of having to type in the num-
bers, all you have to do is choose the tool
preset from the Tool Presets palette or 
pop-up palette.

You can also save presets for type (complete
with font, point size, and color attributes),

and for selection tools, brushes, gradients, 
patterns, shapes, contours, and styles.

The Tool Presets palette is used for manag-
ing saved tool presets. To have the palette
list the presets for only the current tool,
check Current Tool Only.

Click a tool preset to make it the current
tool, complete with its saved settings.

Tool presets are also accessible from this
pop-up palette, which opens if you click
the tool’s thumbnail on the options bar.
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� The Levels command, applied
via an adjustment layer

� Individual pixels are discernible in this image
because it is shown at 500% view.

� Layers are like clear acetate sheets: opaque where
pixels are present, transparent where there are none. 

A layer effect

Mini-glossary  
Layer
An image can have just a Background (no
layers), or it can have multiple layers �.
Only the currently active layer can be
edited. Individual layers can contain layer
effects; they can be restacked and moved;
you can choose blending options for them;
and you can assign masks to them. They are
transparent where there are no pixels.

Adjustment layer
Unlike a standard layer, modifications made
to an adjustment layer don’t alter actual 
pixels until the layer is merged with the 
layers below it �. You can use them to try out
color and tonal adjustments without having
to commit to those changes immediately. 

Pixels
Pixels are dots that are used to display a 
bitmapped image in a grid onscreen �.

Vector
In addition to pixel imagery, you can also
create paths, shapes, and editable type in
Photoshop, each of which automatically
appears on its own mathematically defined
vector layer �. Vector elements print at the
printer resolution, not the file resolution.

Foreground and Background colors
The current Foreground and Background
colors are shown in the Foreground and
Background color squares on the Toolbox
and on the Color palette. The Foreground
color is applied when you use a painting
tool, create type, or use the Stroke com-
mand. The Background color is applied
when you apply a transformation command

An editable
type layer

A shape
layer

�

(Continued on the following page)
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to, or move a selection on, the Background
using the Move tool.

Selection
A selection is an area of an image that’s 
isolated via a “marching ants” marquee; the
unselected area is protected from editing �.
A selection can be created by using a selec-
tion tool (e.g., Lasso), by using a command
(e.g., Color Range), by converting a path
into a selection, or by loading an alpha 
channel mask as a selection. Another way to
protect part of an image is by using a mask.

Preset
Saved type, gradient, pattern, shape, 
contour, style, or tool settings.

History
Every change that’s made to an image is
saved on the History palette as a separate
state. While an image is still open, it can be
restored to any prior state that’s listed.

Layer effects
Photoshop has ten effects (e.g., Drop
Shadow, Outer Glow, Gradient Overlay) that
can be applied to any layer and are fully
editable (and removable). A style is a saved
effect or combination of multiple effects.

Pixel dimensions, resolution
The pixel dimensions value is the number
of pixels an image contains. The resolution
is the density of pixels per unit of measure
(usually per inch) �.   

Brightness, hue, saturation
Brightness is a color’s lightness �; its hue is
the wavelength of light that gives the color
its name, such as red or blue; saturation is
its degree of purity (amount of gray).

Optimization
Optimization is the preparation of an image
for Web output, and it involves choosing file
format, color, and size parameters. By using
slices, you can apply differing optimization
settings to various areas of an image.

Rollover
A rollover is a change on a Web page (e.g.,
the temporary appearance of supplemental
text or a picture) that occurs when the user’s
mouse is over or clicks on a designated area.

� A selected area of an image

Hue slider

B
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� The Photoshop Color Picker

Saturation range

� The Image Size dialog box is used for changing an
image’s pixel dimensions and/or resolution.
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Production techniques
Keep these ideas in mind for future refer-
ence (don’t worry, we’ll explain them later!):

■ To undo the last modification, choose 
Edit > Undo (Ctrl-Z/Cmd-Z)(Note: Some 
commands can’t be undone.) To undo
multiple steps, click a prior state on the
History palette or use the History Brush
tool to restore selective areas.

■ Drag across an option name (e.g.,
“Opacity” on the Layers palette) to the
left or right to change a value without
having to type it in the field.

■ Use the File Browser to search for, sort,
open, move, rename, and delete files, 
and to activate Automate commands.

■ Periodically click the New Snapshot but-
ton at the bottom of the History palette 
to save temporary versions of your image.
Click a snapshot thumbnail to revert to
that version. 

■ Use adjustment layers to try out tonal and
color adjustments, and then later merge
them downward to apply the effect, or 
discard them to remove the effect. Use
the Layers palette Opacity slider to lessen 
the impact of an adjustment layer. 

■ Use Edit > Fade (Ctrl-Shift-F/Cmd-Shift-F)
to lessen the last applied filter, adjustment
command, or tool edit without having to
undo and redo—and choose an opacity
and blending mode for the command
while you’re at it.

■ Memorize as many keyboard shortcuts 
as you can. Start by learning the shortcuts
for choosing tools. Use onscreen tool tips
to refresh your memory, or refer to pages
7–10 or our shortcuts appendix. Shortcuts
are included in most of the instructions
in this book. 

■ Choose the lowest possible resolution and
dimensions for your image, given your
output requirements. Note that vector 
layers (editable type, shapes, and vector
masks) print at the printer resolution—
not at the file resolution. 

Build your image using layers 
You can work on one layer at a time without
affecting the other layers, and discard any layers
you don’t need. You can conserve memory
when you’re working on a large image by merg-
ing two or more layers together periodically. 

Using a layer mask or a vector mask, you can
temporarily hide pixels on select areas of a
layer. When you’re finished using the mask, you
can either discard it or permanently apply its
effect to the layer.

Quick on the redraw
To speed performance, choose Palette Options
from the Layers, Channels, or Paths palette
menu, then click the smallest Thumbnail Size.

new

new

(Continued on the following page)
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■ Interrupt the screen redraw after execut-
ing a command or applying a filter by
choosing a different tool or command.  

■ Save any sequence of commands that you
use frequently in an action so it can be
applied quickly and easily to any image. 

■ Display your image in two windows simul-
taneously, one at a larger zoom level than
the other, so you don’t have to constantly
change zoom levels. 

■ Save any complex selection to its own
grayscale channel, called an alpha chan-
nel, which can be loaded and reused on
any image whenever you like. Or even
better, create a path or a vector mask,
which occupies significantly less storage
space than an alpha channel and can 
be converted into a selection at any time.

■ Use Quick Mask mode to turn a selection
into a mask, which will cover the pro-
tected areas of the image with transpar-
ent color and leave the unprotected area
as a cutout, and then modify the mask
contour using a painting tool. Turn off
Quick Mask mode to convert the cutout
area back into a selection.

■ CMYK files process more slowly than RGB
files. You can work in RGB Color mode,
using View > Proof Setup > Working
CMYK to preview your image as CMYK
Color mode, and wait until it’s done to
convert it to the “real” CMYK Color mode. 

■ Try to allot at least 50% of available RAM
(at least 128 MB) to Photoshop, or four
times an image’s RAM document size. 

■ Choose the Edit > Purge submenu com-
mands periodically to regain RAM that
was used for the Clipboard, the Undo
command, the History palette, or All 
(of the above) �. The Purge commands
can’t be undone. 

� Use the Purge submenu
commands to free up memory.

� Right-click/Control-click with a selection tool to
choose from yet another list of commands.

� Right-click/Control-click with a type tool to choose
from a list of type commands.

� You can choose
some palette commands

via context menus.

Context menus save time
To choose from an onscreen context menu,
right-click/Control-click a Layers, Channels, or Paths
palette thumbnail, name, or feature �. Or choose
general commands or options for the current tool
by right-clicking/Control-clicking in the image 
window �–�. 




